windows10seeeduino lorawanusb

Seeeduino LoRaWAN USB port error

Hello Everyone


I bought a Seeeduino LoRaWAN and wanted to try it out. I tried to install the Seeeduino LoraWAN driver but I couldn't get the installation to run successfully. Nontheless, the device was recognized by Windows and in the Arduino IDE so i didn't mind.

First, everything worked well with some Blinking examples doing exactly what they should.

Then when I was working on a LoRa OTAA example the Seeeduino disconnected and I can't get any computer or OS to recognize the device. I can't exactly say if it disconnected while uploading code or even before that. Just that the upload failed because the previously used COM port was not available anymore.


So far I have tried to reset the board by holding the reset button for atleast a minute and connect the device to different PCs running Windows 7 x64 and Windows 10 x64 with each of them responding with"Windows stopped this device because it reported problems. Code 43".

I tried to install all different kind of USB drivers, including the newest USB-serial driver found on the Seeed-Studio Github page (lastest commit september 7th 2017) but with no success.

When trying to install a driver on top of the faulty device entry Windows either thinks it already does have a better driver or when I try to force it to install the driver a message says that"the folder does not contain a compatible software driver. If the folder contains a driver make sure it is designed to work with Windows for x64-based systems"


Has anyone encounter the same or a similar problem? Or has any idea what I could try next to regain access to the Seeeduino LoRaWAN?

thomas.joeslerOct 30,2017 22:56 PMAdd Comment

Comment

Popular Topics